Express 5 25 1X10 bad overdrive

5:25 and 5:50's

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
Brian Blondahl
Bottle Rocket
Posts: 1
Joined: Tue Oct 12, 2021 10:39 pm

Express 5 25 1X10 bad overdrive

Post by Brian Blondahl » Tue Oct 12, 2021 10:45 pm

I'm noticing that all settings except clean suddenly have too much overdrive. On crunch I cant get past 12 noon before the distortion is overwhelming. Not as bad on Blues but very bad on Burn. I'm in the process of swapping out preamp tubes one by one. Power tubes are new and the amp plays clean when I plug in the return jack of the effects loop so the power section is OK. Anyone else have the same problem? Hoping for an easy fix but not expecting miracles.

User avatar
Don
Single Recto
Posts: 1458
Joined: Sat Jan 12, 2008 12:32 pm

Re: Express 5 25 1X10 bad overdrive

Post by Don » Wed Oct 13, 2021 7:26 pm

You haven't unplugged and plugged the reverb cables back in, have you? Swapping the cables can increase the gain pretty dramatically.

User avatar
DrKev
Bottle Rocket
Posts: 5
Joined: Mon Sep 27, 2021 6:28 am
Location: Paris, France
Contact:

Re: Express 5 25 1X10 bad overdrive

Post by DrKev » Fri Oct 15, 2021 3:06 am

All settings *except* clean, which suggests a preamp issue. That means tubes V2 (which is the input tube on these amps) or V1 (which comes after the tone stack but before the master volume), or something else. Looking at the schematic (non-expert disclaimer) I there is only a small section that is common to crunch, blues and burn, and V2B is in that path.

How did the tube swapping go, Brian?

Did you try emailing Mesa?
Guitar Teacher and Guitar Tech, Folder of Underpants, Stubber of Toes.
Paris, France

Post Reply