DC-2 Rhythym Channel Sounds Weak / Sick

DC-2, 3, 5, 10
50 Caliber

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
lookstoomuch
Bottle Rocket
Posts: 3
Joined: Wed Jul 21, 2021 7:37 pm

DC-2 Rhythym Channel Sounds Weak / Sick

Post by lookstoomuch » Wed Jul 21, 2021 7:45 pm

Hi All! New here, and in need of a bit of help. I turned on my studio caliber which sat for a while and all was normal then eventually the Rhythym channel started sound a bit weak / sick almost like a bit of tremelo was applied. I replaced both power tubes with some JJ's and also did the bias mod by piggy backing the 470K resistor, with no change. So I did a quick recording to demonstrate where I toggle between lead / rhythym.

https://www.youtube.com/watch?v=MhCvysuB1L8

Any ideas?

lookstoomuch
Bottle Rocket
Posts: 3
Joined: Wed Jul 21, 2021 7:37 pm

Re: DC-2 Rhythym Channel Sounds Weak / Sick

Post by lookstoomuch » Thu Jul 22, 2021 9:46 am

Well, even though I had replaced all preamp tubes a few years back, decided last night to swap one by one with a new batch I just purchased.

After doing the first one (closest to the reverb connections), believe this is V6 the P/I tube, everything cleaned up and the amp sounds great.

Guess this makes sense as the initial testing I did involved removing one Power Tube at a time and at the time concluded it was a power tube as it sounded OK with one tube in but not the other.

Think this P/I tube issue would also lead to the "tremelo" like sound it was making. I don't think it explains why the lead channel sounded oK but perhaps the distortion just better masked it better.

lookstoomuch
Bottle Rocket
Posts: 3
Joined: Wed Jul 21, 2021 7:37 pm

Re: DC-2 Rhythym Channel Sounds Weak / Sick

Post by lookstoomuch » Fri Jul 23, 2021 9:00 am

And just like that, the issue returned. Looks like I jumped to a conclusion to quickly. Seems to be intermittent and happens when toggling between rhythm / lead.

I'll keep hacking away, in the mean time if anybody has any tips....

Post Reply