.50 Caliber '87 (EL84) - I Need help!

DC-2, 3, 5, 10
50 Caliber

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
dann.valentino
Bottle Rocket
Posts: 7
Joined: Mon Aug 22, 2016 5:51 am

.50 Caliber '87 (EL84) - I Need help!

Post by dann.valentino » Mon Aug 22, 2016 6:49 am

Problem fixed.
Last edited by dann.valentino on Wed Jan 31, 2018 2:35 am, edited 2 times in total.

Cordwangle
Bottle Rocket
Posts: 2
Joined: Tue Aug 23, 2016 4:47 pm

Re: .50 Caliber '87 (EL84) - I Need help!

Post by Cordwangle » Tue Aug 23, 2016 5:06 pm

Hello - just a thought: check mains transformer has all secondary connections made; sounds crazy but I worked on a studio 22 & all dc voltages across the board were low...!
Took me a while but traced problem back to mains tx which had one of the red, sec leads blanked off (on cct diagram it's R1 or R2 - both of the red leads feeding the rectifier diodes D2-D5; only one set of diodes was effectively connected...!!)....amp worked fine but was even better/louder obviously after connecting all sec tx leads - plus, all dc voltages now very close to schematic values.
May not be the fault that you're experiencing but worth a look eh...?!
Cheers, Paul
P.S.: the transformer for USA can be converted to UK voltage by connecting the primaries in series instead of parallel (connect mains neon across half primary to protect it from over-volts)... :-)

dann.valentino
Bottle Rocket
Posts: 7
Joined: Mon Aug 22, 2016 5:51 am

Re: .50 Caliber '87 (EL84) - I Need help!

Post by dann.valentino » Sun Feb 12, 2017 12:38 pm

Problem fixed.

Post Reply