Page 1 of 1

Groundloop with Mesa Formula and Studio Pre

Posted: Sat Jun 08, 2019 7:04 pm
by Chris89
Hey Guys,

I recently bought a Mesa Formula Pre after using the Studio Pre as my main sound for almost 10 years. Since I also want to use all channels on the formula pre together with some pedals I also bought the new super switcher from EHX which has two control switches. And here comes the problem:

When hooking up the two external inputs for switching between Rhy and Lead 1 and Lead 1 & 2 with the two control outputs from the super switcher, I'm getting a massive groundloop (even if the super switcher is NOT connected to any power whatsoever). This problem also ONLY occurs when the guitar is plugged into the switcher and then into the amp. If I connect the guitar directly into the preamp with the two control outputs plugged in, everything is fine.

Is there anything I need to know about which cables I need to use when it comes to the external channel switches? Shielding? TR vs TSR?

Any help is much appreciated!

Cheers and thanks in advance,

Chris

Re: Groundloop with Mesa Formula and Studio Pre

Posted: Sun Jun 16, 2019 5:49 am
by MesaMad1378
Hey Chris,
You need an isolator in the circuit from the 2nd Preamp out, back to the Super Switcher. Something like the Ebtech Hum Eliminator or a Radial Bigshot ABY, I use both, one for the Mesa Recto Recording and the other for a Marshall JMP-1 and nothing for the Mesa Triaxis.
The Radial ABY has switches to select ISO, Ground and 180 phase so it is good for fault finding ground loops in bigger systems to.

http://www.morleypedals.com/hum-eliminators/

http://www.mooloolabamusic.com.au/radia ... cher-pedal

Hope this helps

Brett