2:90 led problem

Triaxis, Quad Preamp, Stereo Power series, Recto Preamp

Moderators: Guitarzan, Grandor, ned

Post Reply
Olivier V.Girard
Bottle Rocket
Posts: 1
Joined: Fri Feb 01, 2019 10:30 pm

2:90 led problem

Post by Olivier V.Girard » Fri Feb 01, 2019 10:39 pm

Hi!

Long story short, when I activate one fonction, the led light up. Good.

If I activate a 2nd function, both led light but are dimmer.

If I activate all 3 functions, both "Modern" and "Deep" led are dimmed and "1/2 Drive" light become very faint.

What is going on?

Thanks!

MesaMad1378
Mark II
Posts: 61
Joined: Tue Sep 15, 2015 4:49 pm
Location: Gold Coast, Australia

Re: 2:90 led problem

Post by MesaMad1378 » Sun Mar 31, 2019 12:44 am

Hi there,

Mine does the same, after a little while they get a bit brighter🤷🏻‍♂️
Mesa Dual Rectifier, TriAxis, Recto Recording,
2:90, 2:100, SUS-4 16ru Case,
Flux Five, Throttle Box EQ, 5 Band EQ,
Straight Traditional 4x12 Cabs.
And other stuff!!

Henz
Mark II
Posts: 102
Joined: Wed May 18, 2016 11:05 pm

Re: 2:90 led problem

Post by Henz » Sun Mar 31, 2019 12:49 pm

It sounds like that you have the blue light version though the red version may do it too. Mine is blue lite. That always bothered me too. With my experience, the line voltage made a difference. But when it started to get real bad and would start to flicker, it was due to the flaw in the design of the plastic clip going to PCB from power transformer which supplies the 6 volts for them. It was melting. And the two 10,000 uf caps supplying the switching matrix were leaking. Let's hope it's just a low line voltage issue here. Jim
MKIIC+
2:90
4x12 Recto Cab w/ Eminence and V30's
Home made 2x12 half open cab w/ Eminence and V30's
Rocktron Patchmate, Rocktron Intellifex, TS10 Tubescreamer

MesaMad1378
Mark II
Posts: 61
Joined: Tue Sep 15, 2015 4:49 pm
Location: Gold Coast, Australia

Re: 2:90 led problem

Post by MesaMad1378 » Sun Mar 31, 2019 8:22 pm

Hey Henz,
Long time since I’ve been on here, how are you doing?
Mine had a Power Tube go a few months ago and blew an output fuse. Changed the tubes and put a new fuse in but all good so far.
I’m needing to recap mine I think.
Mesa Dual Rectifier, TriAxis, Recto Recording,
2:90, 2:100, SUS-4 16ru Case,
Flux Five, Throttle Box EQ, 5 Band EQ,
Straight Traditional 4x12 Cabs.
And other stuff!!

Henz
Mark II
Posts: 102
Joined: Wed May 18, 2016 11:05 pm

Re: 2:90 led problem

Post by Henz » Sun Mar 31, 2019 11:22 pm

Im fine. thanx. can you pull her out and pop the lid and take a look around? Last July I did a complete recapp. Every electrolytic cap was replaced. Reason being is that I had other issues goin on and sent it out for a quote. Almost cost as much as the amp new. Anyway, I did all the work myself. The quote didnt include recap. Since I had board lifted and tended to issues, i just went ahead and recapped it while it was all apart. What a huge difference it will have for you. Give me a yell if i can be of assistance. Blessings, Jim
MKIIC+
2:90
4x12 Recto Cab w/ Eminence and V30's
Home made 2x12 half open cab w/ Eminence and V30's
Rocktron Patchmate, Rocktron Intellifex, TS10 Tubescreamer

Post Reply