Page 1 of 1

TA30 112 LED problem

Posted: Mon Nov 11, 2019 2:31 pm
by Faff
Has anyone else had this issue?

My amp started cutting out. I found is that the amp crackles and cuts out completely when the LEDs are connected. When they are disconnected, all is OK.  I have tried some other generic 12V LED strips and and  same thing happens so it is not the actual LED strips. 

I'd like the LED to work but it's obviously not critical they are connected. Is is a symptom of something that's going to get worse?

Any ideas anyone please?

Regards

Peter

Re: TA30 112 LED problem

Posted: Tue Nov 12, 2019 1:21 pm
by bgh
I have not had that issue with mine.

Does it exhibit the same behavior when you change wattage?

Re: TA30 112 LED problem

Posted: Tue Nov 12, 2019 2:01 pm
by Faff
Yes it does.

Re: TA30 112 LED problem

Posted: Wed Nov 13, 2019 11:45 am
by bgh
Not to sound like a pat answer, but give Mesa a call. They are excellent with help for things like this.

Re: TA30 112 LED problem

Posted: Wed Nov 13, 2019 2:25 pm
by Faff
bgh wrote:
Wed Nov 13, 2019 11:45 am
Not to sound like a pat answer, but give Mesa a call. They are excellent with help for things like this.
Hi bgh

Thanks for taking an interest. To be honest, I am not getting any useful help from Mesa in UK. I submitted a support request with plenty of detail and basically got a reply saying I need to send it to the service centre for them fix it. I then asked for details of the tech bulletins that are mentioned on this forum which Service Centres in other countries have sent to their customers. They will not send any info out. I asked if there is a specific mention on their repair database of this exact issue. No info given. Not at all helpful. The only thing he says is to ship it to him.

I am reluctant to ship this off as I need to find suitable, packaging, padding and with insurance the return cost is likely to be £100 - and that's before the cost of repairs. I do love this amp and I also have a TA15 head but this lack of basic help (compared it sounds like, to other countries) is pissing me off.

Peter