TA-30 Inevitable Problems?

Discussion area for Transatlantic and Royal Atlantic.

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
Voodoo Child77
Mark II
Posts: 52
Joined: Wed Aug 29, 2012 10:31 am

TA-30 Inevitable Problems?

Post by Voodoo Child77 » Fri Oct 18, 2019 6:16 pm

I found a TA-30 for the right price, but remember reading a few complaints/problems from members on this board. Are they all problematic when it comes to the reverb and effects loop? Should I look for a TA-15 instead? Thanks for any help.

bgh
Mark III
Posts: 288
Joined: Tue Apr 17, 2012 10:01 am

Re: TA-30 Inevitable Problems?

Post by bgh » Fri Oct 18, 2019 9:39 pm

I think the problems were more associated with the earlier production models. I bought mine used and have had no issues with the loop. If you want, I can get the serial number range for mine. But, it will have to be after the weekend - mine is at church right now.

The only "issue" I have had is some of the wattage settings may have some hiss ... depending on which outlet I plug into.
Lefty guitars: Gibson SG standard (1977) • Gibson LP custom (1979)
Amps and such: Mesa Boogie Mark IV-B • Mesa Nomad 45 • Mesa TA-30 • Effectrode Blackbird • Kingsley Jester • AMT SS-11a • Zoom G5

Voodoo Child77
Mark II
Posts: 52
Joined: Wed Aug 29, 2012 10:31 am

Re: TA-30 Inevitable Problems?

Post by Voodoo Child77 » Sat Oct 19, 2019 7:44 am

I would appreciate that. Thank you.

bgh
Mark III
Posts: 288
Joined: Tue Apr 17, 2012 10:01 am

Re: TA-30 Inevitable Problems?

Post by bgh » Thu Oct 24, 2019 10:49 am

We didn't have practice last night. I will have to get it for you on Sunday. Sorry.
Lefty guitars: Gibson SG standard (1977) • Gibson LP custom (1979)
Amps and such: Mesa Boogie Mark IV-B • Mesa Nomad 45 • Mesa TA-30 • Effectrode Blackbird • Kingsley Jester • AMT SS-11a • Zoom G5

bgh
Mark III
Posts: 288
Joined: Tue Apr 17, 2012 10:01 am

Re: TA-30 Inevitable Problems?

Post by bgh » Sun Oct 27, 2019 7:23 pm

Mine is in the TA30-0028xx serial number series.

Again, sorry about the delay in getting back to you.
Lefty guitars: Gibson SG standard (1977) • Gibson LP custom (1979)
Amps and such: Mesa Boogie Mark IV-B • Mesa Nomad 45 • Mesa TA-30 • Effectrode Blackbird • Kingsley Jester • AMT SS-11a • Zoom G5

dwagar
Bottle Rocket
Posts: 1
Joined: Sat Nov 19, 2016 12:04 pm

Re: TA-30 Inevitable Problems?

Post by dwagar » Mon Oct 28, 2019 7:10 am

I bought mine (1x12) used 5 or 6 years ago. I don't use the loop but I do use reverb.

Weekly practices, 8 or 10 gigs a year, zero issues.

It's still one of the best sounding amps I've ever used. And it is the most reliable.

philh27
Bottle Rocket
Posts: 9
Joined: Tue Oct 23, 2012 2:01 pm

Re: TA-30 Inevitable Problems?

Post by philh27 » Sat Nov 02, 2019 4:46 pm

I found a TA30 1 x12 combo a few weeks ago to partner my Lonestar in a stereo set up. It is truly wonderful. Everything I hoped for and more. I don't tend to use FX loops and use a Ventris for reverb, so I wasn't concerned about the notorious noise issues. Having tested it out, I do have to report though that barring one strange very minor issue that I've posted about in a separate theead, I've not experienced any such issues. In fact I'd go so far to say that the loop is possibly the best I've ever tried.

Obviously orhers have experienced problems, but if the loop/ reverb isn't vital to you, then go for it.

Voodoo Child77
Mark II
Posts: 52
Joined: Wed Aug 29, 2012 10:31 am

Re: TA-30 Inevitable Problems?

Post by Voodoo Child77 » Sat Nov 02, 2019 5:03 pm

Thanks for all of the replies. The plan for this amp wouldn't require the loop or reverb so I guess I'm good to go. But...things may change down the road and hopefully I don't run into the problems.

Post Reply