Microphonic tubes in the royal?

Discussion area for Transatlantic and Royal Atlantic.

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
diddlydan
Mark II
Posts: 141
Joined: Sat Mar 15, 2014 7:56 am

Microphonic tubes in the royal?

Post by diddlydan » Wed Oct 26, 2016 6:03 pm

When i first got the amp (new) about 2 months ago, i did notice that if i tapped the front of the amp where the knobs are,it sounded like i was tapping the tubes and they were about to go into self oscillation.Pretty much the classic sound of a microphonic tube.Was recording in the studio earlier and noticed some weird rattles coming in on certain notes on the E string.Pretty sure its a bad tube or 2.Just wondering if anyone else Royal makes a similar sound when they tap the front gently.Im gonna swap a few tubes out tomorrow anyway to be sure.Cheers

bandit2013
Triple Recto
Posts: 3143
Joined: Fri Feb 22, 2013 7:31 am
Location: North Carolina

Re: Microphonic tubes in the royal?

Post by bandit2013 » Sun Oct 30, 2016 7:55 pm

The only rattles I have gotten were from the power tubes. The small bottle and some of the larger variants do make noise. I have a set of Mullards in my RA100 combo that do not make any noise at all except for what I hear from the speakers, and that would be me making the noise.

Sounds like you may have a preamp issue. What channel does it affect?

diddlydan
Mark II
Posts: 141
Joined: Sat Mar 15, 2014 7:56 am

Re: Microphonic tubes in the royal?

Post by diddlydan » Mon Oct 31, 2016 6:10 am

All sorted.Was actually the fx loop tube in the end.Cheers

Post Reply