Page 1 of 1

Footswitch Issues

Posted: Tue Apr 09, 2019 10:07 pm
by Rich G.
Hi! New member, First post... though a long time member at various other forums such as The Gear Page and the Fractal Forum.

I have a Mark V 90 Watt combo amp that has developed a peculiar issue with the footswitch.

When I turn on the amp with the footswitch connected, the LED's on Ch 1, 2 & 3 come on. At this point, if I select any other switch other than a channel switch the LED turns on/off accordingly. When I go to select a channel, all the led's go out. Now I can no longer select any of the other switches.

If I turn the amp off and back on, then the whole process starts over. All channel LED's come on... until I hit any particular channel.

Sometimes I can hit a different channel button and it will work right, but then after no more than three channel selections it stops working again.

Here's what I've done so far...
* Rang-out the cable. Seemed fine.
* Tried DeOxit D5 on the 8-Pin plug and receptacles. No change.
* Checked ground connection between amp chassis and footswitch. Checks out ok.
* Got a new footswitch. Exhibits the same problem.
* Got a new cable. Still have the same problem.

At this point I figure it must be something in the amp. I pulled the amp apart and opened up the footswitch. When I measure voltages on the connector pins on the footswitch circuit board I get 24 Vdc on one pin, 12 Vdc on two pins, and 5 Vdc on one pin. When I hit a channel switch, the 5 Vdc pin drops to 1 Vdc. So, I'm losing the 5 Vdc somewhere. I suspect the 5 Vdc regulator is bad, but now I'm starting to get inside the amp without a schematic. If I use the rotary switch on the back of the amp, the amp will change channels accordingly.

Here's where I could use a little guidance. Anyone have this issue?

Re: Footswitch Issues

Posted: Sat Jul 13, 2019 8:18 pm
by Rider1260
I have had issues with my foot switch also.
you can make it better the ground tab on the amp there is a mod and this helps along with stress relieving the cable.

Much better for me after doing this.

http://www.dirtyhurricane.com/gear/Mesa_FTSW_FIX.pdf