Page 1 of 1

EFFECTS BUFFERING

Posted: Tue Dec 19, 2017 4:15 pm
by micky mesa
Is the Effects Loop on a Lonestar Buffered seems like it looses a little bit of clarity when the effects loop in activated

Re: EFFECTS BUFFERING

Posted: Tue Dec 19, 2017 5:50 pm
by screamingdaisy
micky mesa wrote:Is the Effects Loop on a Lonestar Buffered seems like it looses a little bit of clarity when the effects loop in activated
It is, and all Mesa's are like that. They hard bypass the loop when not in use, which removes a lot of circuitry out of the audio path instead of leaving it inline all the time.

Re: EFFECTS BUFFERING

Posted: Tue Apr 09, 2019 12:52 pm
by edge59
I can see from the version 1 schematic they some what altered the circuit compared to the Mark I reissue, and some of what they did can squash the signal a bit killing the transparency of the tone, as some loops can. I will be making some tweaks on my version 2 to try to remedy it to a acceptable level. But I need a schematic for the version 2 with 100, 50, and 10 watt settings, as the seller did not inform me it had issues due to plugging a power tube in with a broken key pin, causing circuit damages... they have zener diodes that squash/compress the signal and a local feedback network that limits the high frequencies to where it also kills some tone, trying to not overload the effects. My old Reissue mark I was fine without the extra smog crap. So I am thinking, remove some of the components that are not in the reissue and see how that works and go from there. If your interested I will follow up on this when I can.