The Boogie Board

Discussion Forum for Mesa Boogie Products
It is currently Fri Dec 15, 2017 3:21 am

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sun Feb 26, 2017 12:12 pm 
Offline
Bottle Rocket

Joined: Sun Feb 26, 2017 11:27 am
Posts: 18
Item...1988 Mark III Blue Stripe
I once owned a Mark III no stripe from 1985...serial # 15924. I know what SimulClass sounds like as well as that singing lead channel. It stayed with me ever since the beginning so when I cranked up my 1988 blue Stripe, I knew there was something off.
1- The amp is a tad bit noisy
2- The lead channel sounds like a fuzz pedal. Very poor tone
3- The clean channel sounds good.
4- The R-2 channel has very, very strong mids, poor, flubby bass/bottom end.
5- The EQ has very limited range. The slightest adjustment makes a huge leap from no bottom end to extreme. Same as mids and highs.
6- Lacks tube tone response of any kind. I put all new Mesa Tubes throughout but to no avail it made no difference in performance or tone.
7- All tubes light up.

I have contacted Mesa and they want me to send it in however I live in a very remote part of Canada and sending it to them will costs hundreds in shipping…I kid you not. As a last resort I will send it but I am begging anyone out there know can help me please do so. I am a mature male and follows instructions very well. I am very confident that I can make this amp right again.
All the filters and caps look great. No leaking or bulging.
The choke located in the middle of chassis vibrates very much. Is that normal?
The other choke located next to transformer vibrates lightly. Is that normal?
The circuit board has had extremely light corrosion on it but I cleaned it up.
I have the schematics and although I am not a tech, I can follow suggestions/ideas well.

Right now the amp is worthless to me just sitting around not being used. My conscience will not allow me to sell it to anyone in its present condition. Like I said earlier, I will send it to Boogie as a last resort.

I am asking you all, begging you all, please stick with me and help me if you can,

Kindest Regards and Cheers, Paul


Top
 Profile  
 
PostPosted: Mon Feb 27, 2017 6:09 pm 
Offline
Donating Member

Joined: Thu Jul 09, 2009 1:41 am
Posts: 375
Location: Canberra, Australia
G'Day Paul,
I'm in Oz.. postage/freight from here is even more horrific - I feel yr pain.. truly..!

Some of the things U describe seem almost normal - EQ touchy..
It'd need a bench, chase a signal, check for anomalies - poss to find no actual fault but abberation of "normal" with some tweaking to make it less responsive..
"Noisy".. accurate description needed incl when it occurs to give any meaningful help..
Re loose choke ( one will be rev drive tranny - it'll have 4 leads not 2) - def tighten. ASAP. Check all chassis-mounted objects INCLUDING jacks/pots.
If clean ch sounds OK that points less to power end and more preamp end.
BUT.. BUT.. not guaranteed. Dare I say needs a bench..
If new tubes throughout and symptoms persis, that leave PCB / component / wiring anomalies. Don't neglect earthing too.

Long story short.. your symptoms are so wide and variable that accurate help here will be bloody hard.

Local tech should be a starting point I'd humbly suggest..

Dave

_________________
Mk I,export,GEQ,cream
Mk IIA,export,rev,cream
Mk IIB,export,rev, tweed tolex !!
Mk IIB,export, rev,GEQ,simul, black
Mk III head,rev,GEQ,cream
Kitty Hawk M1 head
Fender 75, export, 1973,15".
Fender 6G6A Bandmaster 1962
Fender AA763 Bandmaster 1964


Top
 Profile  
 
PostPosted: Mon Feb 27, 2017 8:24 pm 
Offline
Bottle Rocket

Joined: Sun Feb 26, 2017 11:27 am
Posts: 18
McBarry wrote:
G'Day Paul,
I'm in Oz.. postage/freight from here is even more horrific - I feel yr pain.. truly..!

Some of the things U describe seem almost normal - EQ touchy..
It'd need a bench, chase a signal, check for anomalies - poss to find no actual fault but abberation of "normal" with some tweaking to make it less responsive..
"Noisy".. accurate description needed incl when it occurs to give any meaningful help..
Re loose choke ( one will be rev drive tranny - it'll have 4 leads not 2) - def tighten. ASAP. Check all chassis-mounted objects INCLUDING jacks/pots.
If clean ch sounds OK that points less to power end and more preamp end.
BUT.. BUT.. not guaranteed. Dare I say needs a bench..
If new tubes throughout and symptoms persis, that leave PCB / component / wiring anomalies. Don't neglect earthing too.

Long story short.. your symptoms are so wide and variable that accurate help here will be bloody hard.

Local tech should be a starting point I'd humbly suggest..



Thank you Dave,

No doubt it needs serious bench time and an experienced tech...I was just reaching out in desperation in that I could repair myself but your response was the wake up call that I needed.

Deeply appreciate it,
Cheers, Paul

Dave


Top
 Profile  
 
PostPosted: Mon Feb 27, 2017 8:24 pm 
Offline
Bottle Rocket

Joined: Sun Feb 26, 2017 11:27 am
Posts: 18
Thank you Dave,

No doubt it needs serious bench time and an experienced tech...I was just reaching out in desperation in that I could repair myself but your response was the wake up call that I needed.

Deeply appreciate it,
Cheers, Paul

Dave


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group