Dual Caliber 5 acting strange

DC-2, 3, 5, 10
50 Caliber

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
Reaper1984
Mark I
Posts: 26
Joined: Fri Jul 24, 2009 3:40 pm

Dual Caliber 5 acting strange

Post by Reaper1984 » Sat Sep 05, 2015 1:21 pm

I've googled but can't find a description for this.
At first i thought this was an issue with the GEQ but it wasn't. What happens is on the lead channel alone and lead + GEQ, The bass in the tone just drops out, or the highs drops out and the bass is left..then i can twist a little on the knobs or GEQ, and it goes back to normal, or just play on and for a minute or so it goes back to normal.
I've changed the power tubes, but not the preamp ones, but when i look in the manual, it sounds like you never "really" need to change the preamp tubes?!. I don't know how old my amp is, but he said he never changed the tubes, so they were probably originals. What preamp tubes should i get if i need new ones? I'm just using the amp for metal and some funky rhytms on the clean channel.

Reaper1984
Mark I
Posts: 26
Joined: Fri Jul 24, 2009 3:40 pm

Re: Dual Caliber 5 acting strange

Post by Reaper1984 » Sun Sep 06, 2015 2:19 pm

anyone?

macdaddyof9
Mark I
Posts: 23
Joined: Sun Aug 17, 2008 4:23 pm
Location: Rio Rancho, New Mexico

Re: Dual Caliber 5 acting strange

Post by macdaddyof9 » Mon Sep 07, 2015 10:50 am

try spraying out the pots with contact cleaner. I have had similar problems and was gonna replace some pots when I tried this and it worked great. I use DeoxIT.
[img]http://img369.imageshack.us/my.php?imag ... f1.jpg[img]
Mesa Boogie DC-5
Carvin DC-135
Washburn Idol pro WI66washburn bad dog amp
WashburnD82SWCE,Taylor612CE,misc.Yamahas, Ibenez.Fender Squire Bass,Fender Rumble 30
Roland Vdrums,Roland keyboard

Reaper1984
Mark I
Posts: 26
Joined: Fri Jul 24, 2009 3:40 pm

Re: Dual Caliber 5 acting strange

Post by Reaper1984 » Wed Sep 16, 2015 4:58 am

thanks for the tip, but i guess that's not it i googled, and i have no problems with cracking/noise/scratching etc.
It happens without tweaking any knobs! :cry:
i havent flipped all preamptubes yet, only the one closest to the mesa boogie sign on the front cover, "the first preamp" i wonder if anyone knows (dont see anything about this in the manual), which preamp tube or tubes helps the lead/lead geq channel?

User avatar
bendo
Mark III
Posts: 357
Joined: Fri Jul 29, 2011 12:52 pm

Re: Dual Caliber 5 acting strange

Post by bendo » Wed Sep 16, 2015 11:36 am

You may still need to clean your pots. Fizzling cracking isn't the only issue that can occur when the pots need cleaning.

If that does not fix it (it is your cheapest route) then replace the pre-amp tubes.

Anything outside of that will likely need a trip to an amp tech.
BDR529

macdaddyof9
Mark I
Posts: 23
Joined: Sun Aug 17, 2008 4:23 pm
Location: Rio Rancho, New Mexico

Re: Dual Caliber 5 acting strange

Post by macdaddyof9 » Thu Sep 17, 2015 6:46 am

I forgot to mention that cleaning out the jacks is also very important. I think there may be some switches in the loop jacks that can cause issues. I spray then plug and unplug a patch cable and twist several times. I don't really know why but that has fixed a few strange problems too. Over all I've been lucky and not needed a single repair on this amp. Impressive for a 25 year old piece of gear.


Rock on
[img]http://img369.imageshack.us/my.php?imag ... f1.jpg[img]
Mesa Boogie DC-5
Carvin DC-135
Washburn Idol pro WI66washburn bad dog amp
WashburnD82SWCE,Taylor612CE,misc.Yamahas, Ibenez.Fender Squire Bass,Fender Rumble 30
Roland Vdrums,Roland keyboard

Post Reply