The Boogie Board

Discussion Forum for Mesa Boogie Products
It is currently Tue Nov 13, 2018 7:48 pm

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sun Jan 25, 2009 9:00 pm 
Offline
Mark IV
User avatar

Joined: Mon Aug 04, 2008 8:57 am
Posts: 565
Location: Edgewood, KY
I have never really used it because its really weak and sounds bad. I have heard other DC5 users say they love the reverb on theirs. tubes are new, any ideas?

_________________
Image


Top
 Profile  
 
PostPosted: Sun Jan 25, 2009 10:00 pm 
Offline
Mark II

Joined: Fri Feb 15, 2008 7:06 pm
Posts: 141
Location: LA&NY
I have one of the last DC5 heads made so I'm assuming that any upgrades from previous versions were installed. That being said, my reverb is the weakest of all of my amps. I have to go to 7 or higher to get anything resembling a spring reverb. I've changed tanks, cords, and tubes, nothing. I should say that I am comparing it to my Lonestar Classic and various Fenders (BF Twin, Concert II and a Vibro King) and a Bogner Shiva. When ever I need reverb on it, I use ourboard effects.

_________________
LoneStar Classic Head
DC-5 Head

Image


Top
 Profile  
 
PostPosted: Mon Jan 26, 2009 7:07 am 
Offline
Mark IV

Joined: Tue Oct 30, 2007 10:34 am
Posts: 594
Location: Dallas, TX
My DC-10, and previous DC-5, have plenty of reverb for me. When I use it it's never higher than around 3-4 on the clean channel or 5 on the lead channel. Reverb can be just matter of personal taste and I haven't used Fender reverb in years so I can't comment on how mine compares. Maybe you can listen to other DC-5's to see if yours is at least working as it is designed to.

I'm going to be recording some short clips on my amp and will be glad to record my reverb so you can compare. Maybe mine sucks too and I just don't realize it. :lol: Send me a PM with your email if you want me to send you something. May take me a day or two to get to it though.

_________________
Image

DC-5 head, 2x12 Stagecraft w/EVM12Ls, 1x12 Stagecraft w/EVM12L, Digitech GSP1101/Control 2, GT-100


Top
 Profile  
 
PostPosted: Mon Jan 26, 2009 8:52 am 
Offline
Donating Member
User avatar

Joined: Mon Jun 04, 2007 7:58 am
Posts: 4431
Location: Greenville. SC
Compared to a LSC or Fender the reverb is going to sound inferior for sure! On it's own it sounds OK. I think it sounds great in the clean channel and only 'so-so' in the lead channel. I'm not much on spring reverb for distorted tones though. I prefer a hall or something smoother if anything. I'm more a delay effect kind of guy to be honest...

_________________
Mark V:25 | Mini Rectifier 25 | Mini Rec 1x12 | Fractal Audio FX-8
'06 EBMM JP6 (Mystic Dream) | '15 Epi ES-339 PRO (Cherry) | '11 PRS SE245 (Tobacco Sunburst)
'05 PRS SE Soapbar II (Vintage Cherry) | '92 Peavey Predator USA (Custom)


Top
 Profile  
 
PostPosted: Mon Jan 26, 2009 8:57 am 
Offline
Mark IV
User avatar

Joined: Mon Aug 04, 2008 8:57 am
Posts: 565
Location: Edgewood, KY
See in my opinion this may not be working correctly, it doesnt sound good even on the clean channel and is really weak even on 10

_________________
Image


Top
 Profile  
 
PostPosted: Mon Jan 26, 2009 10:17 am 
Offline
Donating Member
User avatar

Joined: Mon Jun 04, 2007 7:58 am
Posts: 4431
Location: Greenville. SC
Pull your tank out and make sure the springs are connected to both sides of the tank. One may have come loose or something causing the effect to be greatly diminished.

_________________
Mark V:25 | Mini Rectifier 25 | Mini Rec 1x12 | Fractal Audio FX-8
'06 EBMM JP6 (Mystic Dream) | '15 Epi ES-339 PRO (Cherry) | '11 PRS SE245 (Tobacco Sunburst)
'05 PRS SE Soapbar II (Vintage Cherry) | '92 Peavey Predator USA (Custom)


Top
 Profile  
 
PostPosted: Sun Feb 22, 2009 12:06 am 
Offline
Bottle Rocket

Joined: Sat Feb 21, 2009 1:34 am
Posts: 7
I just played my friend's DC-5 the other day and the reverb sucked. Even cranked up almost all the way, it was pretty much non-existent. My little Subway Blues on the other hand has one of the best reverbs I've heard.


Top
 Profile  
 
PostPosted: Sun Feb 22, 2009 11:49 am 
Offline
Mark IV
User avatar

Joined: Mon Aug 04, 2008 8:57 am
Posts: 565
Location: Edgewood, KY
everything is in working order and the tubes are new, just crappy verb tis all.

_________________
Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group