Page 1 of 1

Just got another amp - MKIII

Posted: Sat Dec 20, 2008 12:33 pm
by msi
So I just got another mesa. This time it's a Mark III. This is in addition to my two channel Dual Rectifier, Trem-o-verb combo and triaxis/2:90. I'm pretty happy.

Re: Just got another amp - MKIII

Posted: Mon Dec 22, 2008 12:15 pm
by phyrexia
I just got another Mark III as well. Long chassis, simul class. Purple stripe. It was $200 and nonfunctional when I bought it, and I put about $100 into it and it sounds great :D

Re: Just got another amp - MKIII

Posted: Mon Dec 22, 2008 3:48 pm
by msi
What was wrong with it? I got mine for 500 because of a broken pot.

Re: Just got another amp - MKIII

Posted: Mon Dec 22, 2008 4:58 pm
by kiff
phyrexia wrote:I just got another Mark III as well. Long chassis, simul class. Purple stripe. It was $200 and nonfunctional when I bought it, and I put about $100 into it and it sounds great :D
wow, nice!

Re: Just got another amp - MKIII

Posted: Tue Dec 23, 2008 1:04 pm
by phyrexia
The seller told me the OT was blown. He thought it was a 100w amp. After I got it, I looked at the OT and it was a 562003 (simul-class OT). However the power section of the amp had been rewired to look like a 100w amp. So it was all f'd up. Also apparently some resistors in the preamp section were bad. And an LDR needed to be replaced.

So actually I got the amp home and the volume would drop out once it got hot, so I brought it back to the tech. Hopefully no more charges will be incurred. I want to keep it under $300 :mrgreen: :twisted:

Re: Just got another amp - MKIII

Posted: Wed Dec 24, 2008 5:02 pm
by lesterpaul
damn, thats sweet,Vic!!!!

Re: Just got another amp - MKIII

Posted: Tue Dec 30, 2008 10:07 am
by kmanick
msi wrote:So I just got another mesa. This time it's a Mark III. This is in addition to my two channel Dual Rectifier, Trem-o-verb combo and triaxis/2:90. I'm pretty happy.

Nice!
have you tried running the mark III and the Tremoverb together?
I'd be interested in hearing how those two sound together.