Mesa F-30

F-30, 50 and 100's

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
User avatar
TNTRoy
Mark I
Posts: 40
Joined: Tue Dec 16, 2014 6:25 am
Location: 2407 miles from Mesa/Boogie LTD

Mesa F-30

Post by TNTRoy » Tue Feb 23, 2016 12:36 pm

I was playing a few days ago and all of a sudden the volume dropped and I looked at one of the power tubes was glowing really bright. so I shut it off.. I figured the one of the power tubes went bad. so I ordered a new set from Mesa installed them it sounds great but they are running very hot.. I mean after a few min's of playing it gets hot... do I need to take it and get it serviced?? or is this normal? This amp was in perfect condition when I got it. I have only had if for a few months now.. I also have a Rectoverb 50 combo and it don't seem to run that hot after a hour or so of playing...
Guitars
Gibson LPJ

Amps
Mesa Triple Rectifier
Mesa 3/4 open back 412 cab

User avatar
TNTRoy
Mark I
Posts: 40
Joined: Tue Dec 16, 2014 6:25 am
Location: 2407 miles from Mesa/Boogie LTD

Re: Mesa F-30

Post by TNTRoy » Tue Feb 23, 2016 12:38 pm

I have also noticed it is noisy on all channels when the volume is up on the amp with no pedals only guitar pluged in with the volume turned down on the guitar. I am using a Gibson SG guitar 2013 with no mods.
Guitars
Gibson LPJ

Amps
Mesa Triple Rectifier
Mesa 3/4 open back 412 cab

Scottomy
Bottle Rocket
Posts: 3
Joined: Thu Feb 25, 2016 5:35 am
Location: Montreal, Canada

Re: Mesa F-30

Post by Scottomy » Thu Feb 25, 2016 12:38 pm

TNTRoy, I hope you get some replies and don't feel I'm hijacking your tread!

I just bought a used F30 last week and am having the same problem. Even the plates inside one of the power tubes were glowing.

It may have even been too loud for the volume setting but sounds fantastic though until the volume drops out...

Did you have similar symptoms?
S

User avatar
TNTRoy
Mark I
Posts: 40
Joined: Tue Dec 16, 2014 6:25 am
Location: 2407 miles from Mesa/Boogie LTD

Re: Mesa F-30

Post by TNTRoy » Sat Feb 27, 2016 6:42 am

Scottomy wrote:TNTRoy, I hope you get some replies and don't feel I'm hijacking your tread!

I just bought a used F30 last week and am having the same problem. Even the plates inside one of the power tubes were glowing.

It may have even been too loud for the volume setting but sounds fantastic though until the volume drops out...

Did you have similar symptoms?
S
yes when looking at the rear of the amp the left power tube was glowing really bright. But I only have the volume up to about 11:30 or so.. I replaced the tubes but even at lower volumes the power tubes are getting really hot now.. I mean after 15 min's of play (low Volume) burn your finger hot.... But it sounds even better than ever now. Please note I replaced with Mesa tubes...
Guitars
Gibson LPJ

Amps
Mesa Triple Rectifier
Mesa 3/4 open back 412 cab

Scottomy
Bottle Rocket
Posts: 3
Joined: Thu Feb 25, 2016 5:35 am
Location: Montreal, Canada

Re: Mesa F-30

Post by Scottomy » Mon Feb 29, 2016 10:14 am

I changed the phase inverter tube and the power tubes and was able to use the amp at band practice with no issues. Hopefully the PI tube was the problem...

User avatar
TNTRoy
Mark I
Posts: 40
Joined: Tue Dec 16, 2014 6:25 am
Location: 2407 miles from Mesa/Boogie LTD

Re: Mesa F-30

Post by TNTRoy » Tue Mar 01, 2016 7:07 am

Scottomy wrote:I changed the phase inverter tube and the power tubes and was able to use the amp at band practice with no issues. Hopefully the PI tube was the problem...
I will give it a try and see what it does.. Thanks for the help.
Guitars
Gibson LPJ

Amps
Mesa Triple Rectifier
Mesa 3/4 open back 412 cab

User avatar
TNTRoy
Mark I
Posts: 40
Joined: Tue Dec 16, 2014 6:25 am
Location: 2407 miles from Mesa/Boogie LTD

Re: Mesa F-30

Post by TNTRoy » Wed Mar 09, 2016 3:58 pm

Scottomy wrote:I changed the phase inverter tube and the power tubes and was able to use the amp at band practice with no issues. Hopefully the PI tube was the problem...

Which one is the phase inverter tube? i have check the manual but no luck..
Guitars
Gibson LPJ

Amps
Mesa Triple Rectifier
Mesa 3/4 open back 412 cab

Scottomy
Bottle Rocket
Posts: 3
Joined: Thu Feb 25, 2016 5:35 am
Location: Montreal, Canada

Re: Mesa F-30

Post by Scottomy » Sun Mar 27, 2016 11:00 am

Sorry, I haven't logged in in a while...

Looking from the rear it's the leftmost 12ax7a tube, right in the middle of the chassis and directly below the power tubes.

User avatar
OldTelecasterMan
Mark III
Posts: 325
Joined: Wed Apr 02, 2014 1:55 am
Location: California

Re: Mesa F-30

Post by OldTelecasterMan » Fri Apr 01, 2016 2:01 am

Ok...my 2 cents...

I have been using my F30 for freakin years. I have had very good luck with tubes but I replace them all after about 2 years of use. I did gig a lot with it, like to the tune of 60 nights in a year. The F30 is a killer amp. It is small but the tubes get kinda mushy after a while and it isn't noticeable until you put a fresh set in. I keep the old ones for spares. Electronics can take each other out so depending on what goes out things on down the line in the circuit can get smoked or weakened. My thought has always been change tubes on a schedule and adjust the schedule if use goes up too much. Down time sucks, maintenance is much easier to deal with. Trying to remember what tube was replaced and when is a pain.
Boogie F-30
Mark V
Fender Hotrod Deluxe
Two 2X12 Vert. Cabs.
Two 2x12 Compact Cabs.
Telecasters, Gibson Les Paul, Gibson Howard Roberts Jazz Fusion and many more.
http://www.mp3unsigned.com/Peter_Savell

Post Reply