hissing/white noise on my F-50 combo

F-30, 50 and 100's

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
Santuzzo
Mark I
Posts: 21
Joined: Fri Apr 06, 2007 6:30 pm
Location: Amsterdam, The Netherlands
Contact:

hissing/white noise on my F-50 combo

Post by Santuzzo » Fri Nov 28, 2014 11:03 am

Hi,

I have been experiencing some hissing/white noise on my F-50 combo. At first I thought this would only be occurring on the clean channel, but then I figured I go the volume on the clean channel much higher than I do on the gain channel, so when I turned the gain channel volume up, the nose was there as well.
I tried swapping all pre-amp tubes with a fresh tube one at a time, but that did not help.

Could this hissing noise also be caused by a power tube?

Do you guys have any other ideas what could be the problem with my amp and how to solve it?

Any help would be very much appreciated!

Thanks,
Lars
my website - free licks - some of my music

I offer online guitar lessons on Skype in different styles. Send me a PM if interested.

check out my 1st EP 'Sonic Sketches'

waterboy
Mark I
Posts: 26
Joined: Sun Mar 01, 2015 3:30 pm

Re: hissing/white noise on my F-50 combo

Post by waterboy » Sat May 23, 2015 7:46 am

I tried the SPAX7 and it helped a lot. I would suggest giving it a try.
Mesa mark V 25 with Mini rec slant cab, Nova delay in loop, Spark Boost in front, Les Paul Traditional, Epiphone master built acoustic, Mesa F-50 Custom grill

Santuzzo
Mark I
Posts: 21
Joined: Fri Apr 06, 2007 6:30 pm
Location: Amsterdam, The Netherlands
Contact:

Re: hissing/white noise on my F-50 combo

Post by Santuzzo » Sun May 24, 2015 10:40 am

waterboy wrote:I tried the SPAX7 and it helped a lot. I would suggest giving it a try.
Thanks for that suggestion, I actually bought an SPAX7 some while ago, but have not inserted it yet. I kinda got used to the noise ...
my website - free licks - some of my music

I offer online guitar lessons on Skype in different styles. Send me a PM if interested.

check out my 1st EP 'Sonic Sketches'

Post Reply