Dual Rectifier effects loop stuck on.

Discussion area for Single, Dual and Trip Rectifers

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
Mycall1983
Bottle Rocket
Posts: 4
Joined: Tue May 08, 2018 3:21 am

Dual Rectifier effects loop stuck on.

Post by Mycall1983 » Tue May 08, 2018 3:37 am

Hi everyone, First time poster. I have a multi watt dual rec head and my effects loop is stuck on, on the fooswitch. I have all switches on the back panel set to foot switch, and I have had the physical effects switch replaced on the foot switch but it changed nothing. The Chanel switching pops have gotten louder and some pedals in my effects loop have lost tone/signal and sound dirty. Any one had this problem before or any advice please?
Thanks Mycall

User avatar
deeman
Mark III
Posts: 261
Joined: Mon Jan 14, 2013 4:13 pm
Location: Chicago, IL
Contact:

Re: Dual Rectifier effects loop stuck on.

Post by deeman » Tue May 08, 2018 2:50 pm

Have you ruled out a problem with the cable as well?

What happens when you don't have the footswitch plugged in?
Mesa Boogie 2001 3 Channel Dual Rectifier
Ampeg 4x12 Cab
Gibson 2006 Les Paul Studio
https://soundcloud.com/authoritydrive

Mycall1983
Bottle Rocket
Posts: 4
Joined: Tue May 08, 2018 3:21 am

Re: Dual Rectifier effects loop stuck on

Post by Mycall1983 » Wed May 09, 2018 12:40 am

Hi deeman,
Thanks for the reply, I have not ruled out the cable as I don’t have a spare to try unfortunately. All other switches work fine though.

When I do not have the pedal or cable plugged in and I manually select the channel/setting on rear panel that the effects loop is assigned to, the effects loop seems to be stuck on across all channels/setting no matter what channel/setting I’m on (except bypass). So if I manually have the effects loop set to channel 1 but the channel selector manually set to channel 3, the effects loop is still on and if the manual selector is set to foot switch the effects loop works across any channel I manually select and my effects, especially my chorus pedal sound thin but if turn the signal up on the front panel it gets distorted as if the signal is to hot even on the clean channel (channel 1). All effects in my loop sounded fine before the loop was stuck on. I tryd my chorus pedal in front of my other amp and it sounded normal.

I apologise if I sound condescending I’m just trying to be clear as I can to be helpful as I can.

Mycall1983
Bottle Rocket
Posts: 4
Joined: Tue May 08, 2018 3:21 am

Re: Dual Rectifier effects loop stuck on.

Post by Mycall1983 » Thu May 10, 2018 8:14 pm

Any body?

woodbutcher65
Mark III
Posts: 170
Joined: Fri May 04, 2018 10:36 pm

Re: Dual Rectifier effects loop stuck on.

Post by woodbutcher65 » Sun Jun 17, 2018 1:21 pm

I don't have the schematics for the multi-watt version of the dual and triple Recto, but I've fixed two Triples very recently that both had switching issues.

If there's ANY similarity at all between the switching systems I could probably have that sorted out in about 15 minutes. I'd look at the input and output signals going to the IC that controls the switching, located near the back left corner of the main board as seen with the chassis on the bench, electronic side up, knobs forward.

I'd start by unplugging the ribbon connector from the back board where the loop jacks are. That removes all possible input signals that control the loop.

Then if the loop was still on then it'd be most likely to be that switching control IC.

As I recall, the multiwatt units used relays instead of FETs for switching. You may have a stuck loop relay. Wherever that is. See if there's voltage on the relay coil. If it's at coil voltage then something is commanding it. Probably that IC.

I could be more helpful with the schematic to reference, but Mesa has not yet released the multi-watt schematics to anybody. (That I am aware of.)

Post Reply