Roadster making popping noise when switching channels

Discussion area for Single, Dual and Trip Rectifers

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
User avatar
tzoranski
Mark I
Posts: 24
Joined: Fri Oct 21, 2016 5:02 pm
Location: NYC

Roadster making popping noise when switching channels

Post by tzoranski » Fri May 12, 2017 11:23 am

Sorry to be reposting this but I haven't had any luck getting answers to this question in the Roadster Lag Thread.

I have a few questions about the pops that people say can be fix by cycling through the channels in stand by mode. I using my roadster with the G System in the 4 cable method with a RJM mini amp gizmo and the Mesa RRN cable. I tried turning my amp on, leaving it in stand by and cycling through the channels using the mini amp gizmo but I still get pops. When I turn on my amp it's in channel one and I cycle through the channels until I'm back at one then I take it out of stand by. Is that what i'm supposed to do? I don't see any difference.

I also notice a bigger pop when going from CH 2,3 or 4 to CH 1. In order to have CH 1 loud enough without it breaking up I'm engaging the solo on that channel. Giving it some additional volume to compete with the other channels. The popping sound is driving me crazy and I can't figure out how to get rid of it. Any input would be greatly appreciated.

Lastly does anyone know if this popping issue also happens with the Road King 2 or has anyone heard of someone bringing the amp to a tech to fix the issue? Thanks.

User avatar
Eevil
Mark II
Posts: 88
Joined: Tue Sep 13, 2011 4:04 am
Location: Finland

Re: Roadster making popping noise when switching channels

Post by Eevil » Sat May 13, 2017 12:10 am

Does it pop when you change channels from back panel knob or with footswitch?

My Roadster pops once after the standby is off and the channels are cycled thru... but not after that.
Current:
- Electra-Dyne
- Mark V
- 2x12 Recto horizontal
- 4x12 Stiletto slanted
- Gibson R7 Goldtop
- Custom strat
- Ibanez RG2550Z

User avatar
domct203
Moderator
Posts: 3115
Joined: Mon Jan 01, 2007 6:52 am
Location: New Haven, CT U.S.A.
Contact:

Re: Roadster making popping noise when switching channels

Post by domct203 » Mon May 15, 2017 11:57 am

At band volume my Roadster only pops once, then I'm good to go.

Dom
'07 Roadster Voodoo modded
'08 Stiletto Deuce II
'10 Mark V - sold
'18 TC-100
'01 Recto 4X12 Slant
'04 Recto 4X12 Slant/Straight
'74 Les Paul Custom
'95 American Strat
'12 Les Paul Signature T
Voodoo Labs MIDI
==> NOMAD on Facebook <==

Gontur
Bottle Rocket
Posts: 14
Joined: Sun Jan 24, 2016 12:04 pm

Re: Roadster making popping noise when switching channels

Post by Gontur » Tue May 16, 2017 4:48 am

Maybe the problem is your G-System. I've heard many weird stories about Roadster+G-System.
My rig is Roadster + Boss Es 8 (4 cable method) and after cycling 3-4 times through channels pop is almost gone and no audible in rehearshal/live situations.

User avatar
tzoranski
Mark I
Posts: 24
Joined: Fri Oct 21, 2016 5:02 pm
Location: NYC

Re: Roadster making popping noise when switching channels

Post by tzoranski » Wed May 24, 2017 2:49 pm

Eevil : I haven't tired the foot pedal or the switch in the back so I will check that out soon. As I mentioned I'm using the Mini Amp Gizmo for switching the channels.

Dom: Yea, unfortunately I'm playing at bedroom volume. I could try cranking it up to see if I get a change.

Gontur: Well I have heard of other g-system/ roadster users mention the popping but I don't think it's only because of the g-system. I could try taking it out of the loop and see if I still get the pops.

Have you guys ever heard of the Road King II having the popping issues? Thanks again for your input. Going to try some more things this weekend.

Post Reply