The Boogie Board

Discussion Forum for Mesa Boogie Products
It is currently Mon Sep 25, 2017 1:47 pm

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Dual rec effects loop
PostPosted: Wed Apr 19, 2017 8:40 pm 
Offline
Mark I

Joined: Sat Jul 23, 2016 1:17 am
Posts: 30
So i recently started running a TC Flashback delay and a TC chorus in the effects loop. but the effects seem quiet and buried far in the background. i have the send and return both set at halfway point what am i doing wrong i want to bring the effects out more when i kick on the effects loop switch for solo's. Amp is 2007 3 channel


Top
 Profile  
 
PostPosted: Thu Apr 20, 2017 9:40 am 
Offline
Mark II

Joined: Wed Aug 04, 2010 10:32 am
Posts: 85
Location: New Jersey, USA
Do those pedals have wet/dry mix settings? Looking at their basic info, they would not. Do they have level controls for the output?

The problem may be that they are simply not designed to run line level signals. Most stompboxes are made for instrument level signals, so when put into an effects loop they may not work as well.

Have you tried adjusting the loop to be 100% wet?

_________________
Guitars: Hamers, Heritages, G&L Legacies, EBMM Steve Morse, Carvin Bolt, Fender Tele
Amps: DC-5 1x12 w/Master Volume + EFX Mods, Maverick 2x12


Top
 Profile  
 
PostPosted: Thu Apr 20, 2017 2:11 pm 
Offline
Donating Member
User avatar

Joined: Mon Jan 24, 2005 10:36 pm
Posts: 1446
Location: DC Metro Area
Well, we'll need more info to be able to help. The channel volumes also affect your signal when using the loop. I assume this is the Corona chorus you have? If so, both it and the Flashback have a kill/dry switch. Turn that on for both to use them in your loop. If you leave the dry on in the pedals, then turn your loop return level to max and make sure your channel volumes aren't too low. You should have no problems then.

_________________
Boogie user of 20+ years, previous owner of 150+ Rectos, author of the previous "2 Channel Recto User Guide" and current "3 Channel Recto User Guide" (in progress).


Top
 Profile  
 
PostPosted: Thu Apr 20, 2017 4:49 pm 
Offline
Mark I

Joined: Sat Jul 23, 2016 1:17 am
Posts: 30
Thanks i will try suggestions.


Top
 Profile  
 
PostPosted: Sun May 28, 2017 8:44 am 
Offline
Mark II

Joined: Sun Feb 02, 2014 11:51 am
Posts: 85
I have the TC Electronic Corona and X4 Flashback and use them on a little rectoverb in the effects loop no problem. They also work great with other Mesa amps in the effects loop. I have the buffers off and they are set to true bypass. The kill dry is off because the entire guitar signal is going through the pedals (the send/receive is series, not parallel). So, play with those settings on your pedals since they do work well with Mesa amps.

There could be something up with your effects loop. Have you tried just connecting "send" to "receive" directly with a cable to see if you lose signal there?

Mace


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group