Rect-o-verb 50 Series 1 footswitch issue

Discussion area for Single, Dual and Trip Rectifers

Moderators: Guitarzan, Grandor, ned, Platypus

Post Reply
sheehanje
Mark II
Posts: 106
Joined: Thu Sep 03, 2015 8:16 pm

Rect-o-verb 50 Series 1 footswitch issue

Post by sheehanje » Sat Sep 15, 2018 6:45 pm

Hello all - I am just getting back into real tube amps after a few years in the modelling world (line 6 helix) - I've previously owned a Mark V, JP-2C and a mini rectifier. I sold most of my gear, and just wanted a nice simple tube amp - preferably a Mesa, but had to have something that wouldn't set me back too much.

So my local music store had a Rect-O-Verb 50 combo amp for a good price, and I grabbed it. I remember wanted the head version (minus the reverb) a while back - and I am very very pleased with how this amp sounds. So glad I found it as I almost got a Marshall combo because I didn't see the rect-o-verb at first, and all the other Mesa gear was out of my price range.

I do have one issue - the footswitch doesn't seem to be operating properly. I plugged the cable into the amp and footswitch - the solo button seems to work, I haven't tested the reverb button, but the channel button doesn't seem to do anything - although, if I change channels manually with it the light changes from red or off on above the channel selection switch.

Any ideas what to look for? I read the manual, but there was little information on the footswitch. Any help would be greatly appreciated as this is a great amp but not having a working footswitch would be a deal killer and I'd have to return it.

sheehanje
Mark II
Posts: 106
Joined: Thu Sep 03, 2015 8:16 pm

Re: Rect-o-verb 50 Series 1 footswitch issue

Post by sheehanje » Sat Sep 15, 2018 6:51 pm

Actually - I may have found the issue - seems they gave me a series 2 footswitch. The channel selector says "channel" on the series 2 footswitch, and "rhythm" on the series 1 footswitch. Mine says channel, so I'm thinking there is an internal difference between the two series?

This shop moves a lot of used (and new) mesa gear, so I can see where they could easily mix it up.

sheehanje
Mark II
Posts: 106
Joined: Thu Sep 03, 2015 8:16 pm

Re: Rect-o-verb 50 Series 1 footswitch issue

Post by sheehanje » Mon Sep 17, 2018 9:17 pm

All sorted - definitely a different footswitch from series 1 to series 2.

With that all set, I gotta say, Rect-O-Verb 50's were totally underrated. I loved my Mark V, and my JP-2C - but where the former was a tweakers delight, and the later had some really cool modern features - I just love the simplicty of the Rect-O-Verb 50 Combo I got. It has a surprising amount of flexibility in it, and just sounds great. I had a Mini-Rec, but it just didn't deliver like the 50 watt Single Rec's. I'm floored. It's the first Mesa amp I had dialed in perfect within minutes. I can't stop playing. Man - they need to come out with a Series 3!

silentbob
Mark II
Posts: 83
Joined: Tue Nov 18, 2014 11:09 pm

Re: Rect-o-verb 50 Series 1 footswitch issue

Post by silentbob » Tue Sep 25, 2018 5:41 pm

I have a series 1 single recto that is my backup. Great amp, love its simplicity and ability to do mid gain stuff.

Post Reply