The Boogie Board

Discussion Forum for Mesa Boogie Products
It is currently Sun May 20, 2018 5:02 am

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: problem Titan V12
PostPosted: Thu Feb 21, 2013 2:53 pm 
Offline
Bottle Rocket

Joined: Thu Feb 21, 2013 2:48 pm
Posts: 1
Who should I turn to for problem described below.
I wrote to Mesa today, but it would be helpfull to receive some concrete contacts.

Thanks, Zoran

On 16th of December 2010 I bought Mesa Boogie Titan V12 along with Standard 8x10 Powerhouse Mesa Boogie. I bought a new product in Italy - from the Esse music store in the link http://www.essemusic.it/


In September 2012 something went wrong, the smoke came out of the head.
I immediately contacted the Esse music store - the product was still in warranty.
In about three weeks they returned the head and said they solved the problem.

The head worked, untill 14 days ago, when suddenly it crashed.
The sound from box (Standard 8x10 Powerhouse Mesa Boogie) was crunchy and without power.
I tried to plug other bass head (Ampeg B2RE) to the Mesa Boogie box and the sound was crunchy and without power again.
Then I plugged Titan V12 into two boxes Ampeg SVT-410HE and it played normal.
I knew something was wrong with cabinets.

I took the cabinet and head to the repairman Peter Caric in Ljubljana. He is one of the best in this bussines in Slovenia.
His diagnose is: all 8 cabinets have burned their horns (coil, spool) in units.
When he looked at Titan V12 he saw what was repaired (changed).
He described that in the head there are two sets of tranzistors, and that in warranty repair only one of the set was replaced.
So now there are one set of tranzistors from one manufacturer and other set of tranzistor from other manufacturer.
This incompatibility of two sets of tranzistors is the reason why the horns in cabinets have burned.
He said that all output tranzistors and their characteristics must be from the same manufacturer.
Also one tranzistor in the one they changed had a 15A safety fuse insted of 10A - this tranzistor has overburned.

He fixed the cabinet (I had to pay 350 EUR).
The problem will repeat again if we don't fix the problem with tranzistors.

I don't trust Esse music store and their repair service.
Maybe you should press on them to take things like this seriously, because it's your loss if they don't repair your products how they're suppose to.

Zoran


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group