Help needed on JH set install

Discuss guitars of any brand

Moderators: Guitarzan, Grandor, ned

Post Reply
Axxion24
Bottle Rocket
Posts: 10
Joined: Fri Dec 14, 2012 6:32 pm

Help needed on JH set install

Post by Axxion24 » Tue Jan 08, 2013 6:11 pm

i just bought these pickups new. i have the exact same pickup setup in another guitar, but that one has 1 volume and 1 tone. this guitar that i am having trouble with has 2 volume and 1 tone.

my issue i thought was a grounding problem from the three way switch, however i took the entire assembly out of the guitar and laid it on cardboard and there was zero hum or noise like i have when it is installed in the guitar. my wiring is 100% correct. there are no bad connections. but when i plug the thing in there is buzzing that only goes away when i touch something that connects to the circuit. it is not a battery problem. i have got new ones. it is not a cord problem as all my cords do the same thing. it is not my amp as my grounds are fine and my other guitar with the JH set is completely noiseless and when there is buzz, touching the pots or body cavity doesnt change anything.

it seems to me that the body cavity is somehow allowing current to pass through it. how do i fix this? the pots are obviously mounted closely to the cavity and the input jack is also touching it. any suggestions?

here are videos and pictures of my problem in action. the guitar is a esp ltd axxion.

the first video is me touching the body cavity only. no metal parts. the second is obvious.

http://www.youtube.com/watch?v=1qF5zP8M1kY
http://www.youtube.com/watch?v=eUQm3nFMhxU
http://postimage.org/image/k8ma8voiz/

Post Reply