Search found 3134 matches

by domct203
Tue Jun 25, 2019 7:20 pm
Forum: Modern Era Amps (1991-Present)
Topic: Triple crown 100 vs Roadster!?
Replies: 4
Views: 942

Re: Triple crown 100 vs Roadster!?

I thought I should follow up on this thread. It’s been a few months now with my TC-100, and I find myself gravitating to that amp over the Roadster as my main gigging amp even after the ‘honeymoon stage’ Since February I’ve gone back and forth between the two amps 5 or 6 times with the band. In the ...
by domct203
Sat Jun 22, 2019 8:57 am
Forum: Classifieds
Topic: FS - PRS \m/ Metal Pickup Set
Replies: 0
Views: 26

FS - PRS \m/ Metal Pickup Set

For Sale - PRS \m/ Metal Pickups. Uncovered Treble and Nickel Covered Bass set.

Pickups work as they should and sound great, I just prefer my Tremonti Set.

PayPal thru eBay please.

https://rover.ebay.com/rover/0/0/0?mpre ... 3194564903
by domct203
Fri Jun 21, 2019 10:53 am
Forum: Rectifier Series
Topic: NOS 12AX7 tubes for Cathode follower ?
Replies: 6
Views: 224

Re: NOS 12AX7 tubes for Cathode follower ?

3124+ wrote:
Wed Jun 19, 2019 9:51 pm
I've been using Russian 12AX7 tubes (12AX7EH and 12AX7LPS) in Mesa Dual and Triple Rectifier Solo heads for years with no problems.
Are you running in Spongy mode, or using the Recto tubes instead of diodes?

http://www.forum.grailtone.com/viewtopi ... 2&start=16
by domct203
Mon May 20, 2019 5:20 pm
Forum: Tubes
Topic: Lonestar Classic and EH 12AX7's
Replies: 2
Views: 203

Re: Lonestar Classic and EH 12AX7's

I need to replace my preamp tubes due to that annoying microphonic noise. Its been at least six years since they were changed out. Would it be ok to use the Elecrto Harmonix 12ax7's in all 5 positions? I found a good price and I'm on a budget right now so this is one of my only options at the momen...
by domct203
Sat May 18, 2019 6:39 am
Forum: Mark Series
Topic: Mark II fx loop and Boss pedals?
Replies: 2
Views: 203

Re: Mark II fx loop and Boss pedals?

Most stomp boxes are designed for high impedance / lower instrument level signals, like the signal from your guitar. Most FX loops (especially Mesa) are sending a much stronger low impedance (line level) signal through the FX loop. You are overdriving the input of your pedals with the hot signal lev...
by domct203
Fri May 17, 2019 11:29 am
Forum: Mark V
Topic: Mark V distasteful overdriven buzz
Replies: 8
Views: 590

Re: Mark V distasteful overdriven buzz

I had a similar experience with my MKV, but to me it was something in the midrange that I just could not get through.... a harshness that if dialed out in the EQ took all the clarity out of the tone and would bring on the mud. Ended up selling the MKV as that was my impression anytime I played it fo...
by domct203
Sun May 12, 2019 6:45 am
Forum: Rectifier Series
Topic: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN
Replies: 14
Views: 862

Re: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN

Where is the FX Loop send level? If it’s turned all the way down you will be passing very little signal through the FX Loop circuit, even without effects in the loop.
by domct203
Tue May 07, 2019 4:51 pm
Forum: Rectifier Series
Topic: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN
Replies: 14
Views: 862

Re: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN

tbonesullivan wrote:
Tue May 07, 2019 9:57 am
The cathode followers used in the Rectifier put 216V and 210V on V3 and V4 from what I can see.
With the Roadster (and RK), the cathode followers are V3 & V5.

The standard Rectos are V3 & V4.
by domct203
Tue May 07, 2019 4:48 pm
Forum: Rectifier Series
Topic: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN
Replies: 14
Views: 862

Re: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN

Thank you both for the reply. I took it apart just now and confirmed Mesa 12AX7 in V 1-6. If the Mesa 12ax7’s say ‘Russian-1’ they are Sovtek, ‘Russian-2’ and they are EH, both are questionable in cathode follower use. The current Mesa 12ax7 will not have ‘Russian’ or ‘Chinese’ stamp on them, those...
by domct203
Mon May 06, 2019 5:56 pm
Forum: Rectifier Series
Topic: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN
Replies: 14
Views: 862

Re: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN

The Russian 1 does not have the spiral filament, so they are usually fine in Cathode follower positions. The Russian 2 tubes were either EHX or Sovtek LPS tubes, and can torch in the Cathode follower positions. Any of the Slovakian or Chinese tubes should work fine in those slots. Also a great plac...
by domct203
Sun May 05, 2019 4:45 pm
Forum: Rectifier Series
Topic: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN
Replies: 14
Views: 862

Re: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN

Thank you both for the reply. I took it apart just now and confirmed Mesa 12AX7 in V 1-6. If the Mesa 12ax7’s say ‘Russian-1’ they are Sovtek, ‘Russian-2’ and they are EH, both are questionable in cathode follower use. The current Mesa 12ax7 will not have ‘Russian’ or ‘Chinese’ stamp on them, those...
by domct203
Sun May 05, 2019 6:13 am
Forum: Rectifier Series
Topic: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN
Replies: 14
Views: 862

Re: Mesa Dual Rec Roadster Head- Lost Channel 1/2 AGAIN

What brand of 12ax7 are in V3 & V5? Those are cathode follower positions and weak tubes in those spots can create the issue you describe. Best to use only the current Mesa 12ax7 (which is a JJ), or a Chinese made tube (NOS/VOS seem to be fine also). Anything made by New Sensor Corp (Sovtek, EH, Tung...
by domct203
Thu May 02, 2019 5:03 pm
Forum: Rectifier Series
Topic: Roadster Reverb Issue
Replies: 7
Views: 459

Re: Roadster Reverb Issue

Yup cables were backwards reverb works now. Now a new problem came up, a loud ass pop when switching to channel 3. I hope i didnt knock something out of place when taking the chassis out switch the reverb cables. Any one have popping problem when switching channels? I’m guessing this is a new to yo...
by domct203
Wed May 01, 2019 11:12 am
Forum: Rectifier Series
Topic: Roadster Reverb Issue
Replies: 7
Views: 459

Re: Roadster Reverb Issue

dwman3 wrote:
Tue Apr 30, 2019 7:13 pm
.......... the other thing is maybe i didnt put the little RCA connectors from the reverb tank in the right slot.........
Did your reverb work just fine before you disconnected it?

You should at least try swapping the connections, nothing to lose.
by domct203
Mon Apr 15, 2019 5:27 pm
Forum: Rectifier Series
Topic: Multi-watt Dual recto clean ch. problem
Replies: 4
Views: 1478

Re: Multi-watt Dual recto clean ch. problem

How did you go with this? Did you get anywhere? Mine is quiet to compared to ch 1 and 2. If I want it louder it starts to distort and I like my cleans like crystal. Where do you have your channel masters set? I find that to keep the clean channel ‘clean’, I need to keep the lead channel Masters no ...