Search found 3189 matches

by domct203
Thu Jun 04, 2020 5:15 pm
Forum: Rectifier Series
Topic: Can rectifier tubes blow fuse in ss mode?
Replies: 2
Views: 288

Re: Can rectifier tubes blow fuse in ss mode?

The rectifier tubes are always in the circuit, the SS/Tube switch simply switches the diodes in/out.

Yes, a bad rectifier tube can blow a fuse when in SS diode mode.

The fuse is more likely to blow on power up.

Dom
by domct203
Sun Apr 12, 2020 9:49 am
Forum: Modern Era Amps (1991-Present)
Topic: Mini Rectifier disconnected power cable: flash light, smoke and melted plastic. HELP!
Replies: 4
Views: 730

Re: Mini Rectifier disconnected power cable: flash light, smoke and melted plastic. HELP!

Still wondering how the OP made out with their amp, as well as what plastic was melting.
by domct203
Sun Apr 12, 2020 9:47 am
Forum: Modern Era Amps (1991-Present)
Topic: Which modern mesa has the heartbreaker in it?
Replies: 1
Views: 477

Re: Which modern mesa has the heartbreaker in it?

Which modern era mesa boogie amp has the discontinued Heartbreaker in it? I don’t know if there is one, as it’s based on the MKI. From Mesa’s website: “ Conceived as the 25th Anniversary Tribute to the original Mark I, the Heartbreaker is a two channel / five mode, footswitchable rendering of that ...
by domct203
Sun Apr 12, 2020 8:21 am
Forum: Rectifier Series
Topic: Tremoverb Head Low (Diminished) Output
Replies: 6
Views: 853

Re: Tremoverb Head Low (Diminished) Output

Hello all, searching the posts here yielded no results that I wanted to jump on right away, aside from just retubing. I'll start with my problem...I have a DR Trem-O-Verb from August of '94 (serial 4279) and I'm experiencing very very low output on the Orange channel. Red seems fine, loud and full,...
by domct203
Sun Apr 12, 2020 8:18 am
Forum: Rectifier Series
Topic: Tube cover on V2?
Replies: 1
Views: 285

Re: Tube cover on V2?

My MKV had covers on all preamp tubes.

While the amp will work fine without it, the cover acts as not only a retainer for the tube, but an RFI shield as well.
by domct203
Mon Mar 16, 2020 8:33 am
Forum: Rectifier Series
Topic: Tremoverb Head Low (Diminished) Output
Replies: 6
Views: 853

Re: Tremoverb Head Low (Diminished) Output

If you go to Mesa Boogie’s website you can go to the support page and get a list of certified techs in your area. The first three I see in Nashville are: Hime Amplification(5mi) 2127 Utopia Ave, Nashville, TN, 37211, USA P: (615) 562-0089 Nashville Amplifier Ser.(6mi) 2616 Grandview Ave Nashville TN...
by domct203
Mon Mar 16, 2020 8:13 am
Forum: Modern Era Amps (1991-Present)
Topic: Mini Rectifier disconnected power cable: flash light, smoke and melted plastic. HELP!
Replies: 4
Views: 730

Re: Mini Rectifier disconnected power cable: flash light, smoke and melted plastic. HELP!

woodbutcher65 wrote:
Sun Mar 15, 2020 4:17 pm
Don't mess with it. Take it directly to a qualified amp tech and let him handle it.

Any other advice is wrong.
Agree 100%

Out of curiosity, what plastic parts on the amp were melting?
by domct203
Fri Mar 13, 2020 7:26 pm
Forum: Rectifier Series
Topic: Tremoverb Head Low (Diminished) Output
Replies: 6
Views: 853

Re: Tremoverb Head Low (Diminished) Output

bzni wrote:
Wed Mar 11, 2020 8:32 pm
Sounds like you've got a dead LDR in the orange channel.
+1

You should see if there is a Mesa Certified Tech in your area.
by domct203
Mon Feb 17, 2020 8:01 am
Forum: Vintage Amps (Before 1991)
Topic: Modified Boogie Mark I
Replies: 2
Views: 1184

Re: Modified Boogie Mark I

I'm sure some of you guys have seen this, but I was wondering what the general forum opinion is on this one; https://reverb.com/item/26260964-mesa-boogie-mark-white-tolex-late-1970s I know it's collector value is pretty much shot but, it seems like fairly useable mods to help make it a more versati...
by domct203
Fri Feb 14, 2020 8:24 pm
Forum: Rectifier Series
Topic: HELP WITH FX LOOP SETTINGS
Replies: 3
Views: 1089

Re: HELP WITH FX LOOP SETTINGS

If the FX Loop has a Mix knob, it’s a parallel FX Loop. You’ll want to keep the mix at 100%, Send around noon. Just make sure you are not clipping the AD/DA converters in the GT1000, the Recto’s FX Loop is a line level signal and can get hot. If the GT1000 has a ‘kill dry’ feature you could try that...
by domct203
Fri Feb 14, 2020 12:29 pm
Forum: Rectifier Series
Topic: HELP WITH FX LOOP SETTINGS
Replies: 3
Views: 1089

Re: HELP WITH FX LOOP SETTINGS

Hey Metal heads. I am trying to figure out best setting for running my Boss GT1000 into my Triple Rec. Not sure what to have the knobs on back set to. Also, not sure what input level to be at. I am connected via the 4 cable method. I am trying for thick metal sound, with good tight low end. Thanks ...
by domct203
Sun Feb 02, 2020 12:40 pm
Forum: Rectifier Series
Topic: Triple Rectifier ground hum issue
Replies: 7
Views: 1024

Re: Triple Rectifier ground hum issue

Is this a 2 channel or 3 channel amp? The 3 channel version has one triode of V1 used exclusively for channel one. If that specific triode should fail only channel one would be affected as you are experiencing and you could try changing V1. The earlier 2 channel amps did not do that, both channels u...
by domct203
Tue Jan 28, 2020 12:21 pm
Forum: Rectifier Series
Topic: Triple Rectifier ground hum issue
Replies: 7
Views: 1024

Re: Triple Rectifier ground hum issue

If the FX loop is not Hard Bypassed, it’s tube buffer is still in the circuit regardless. When this happens again, flip the FX Loop to Hard Bypass and see if anything changes. If not, you’ve eliminated one of the preamp tubes and the FX Loop circuit as a source of the issue. If the amp roars to life...
by domct203
Sun Jan 26, 2020 7:08 pm
Forum: Rectifier Series
Topic: Dual Rectifier Solo Head - Clean Channel problem
Replies: 1
Views: 687

Re: Dual Rectifier Solo Head - Clean Channel problem

How old are the power tubes?
by domct203
Sun Jan 26, 2020 7:06 pm
Forum: Rectifier Series
Topic: Triple Rectifier ground hum issue
Replies: 7
Views: 1024

Re: Triple Rectifier ground hum issue

Are you using the FX loop when this happens?

Have you tried Hard-Bypassing the FX Loop to see if anything changes?