Search found 7 matches

by xbilx
Fri Mar 22, 2019 6:42 am
Forum: TC50
Topic: What fuzzies do you like with the tc50
Replies: 3
Views: 1655

Re: What fuzzies do you like with the tc50

i have an older v6 big box muff and it doesn't sound great on its own into my tc-100. Well I should say I haven't gotten a tone I like. I keep it on my board though because when paired with a delay I get some great shoegaze tones. For straight fuzz I use the pitch fuzz from my H9 which sounds great!
by xbilx
Fri Apr 28, 2017 7:22 pm
Forum: Rectifier Series
Topic: 2-channel triple troubleshooting help
Replies: 7
Views: 2831

Re: 2-channel triple troubleshooting help

That's definitely not a normal thing to go on a Mesa amp. They use very robust output transformers. However if the amp has been mistreated in the past, such a being turned on without a speaker load, that can blow up output transformers. Was the tech able to tell you anything about why it went? Was ...
by xbilx
Fri Apr 28, 2017 11:38 am
Forum: Rectifier Series
Topic: 2-channel triple troubleshooting help
Replies: 7
Views: 2831

Re: 2-channel triple troubleshooting help

Finally got this into the tech, turns out it was the output transformer. Going to be installing a MM. Tech said that signal is feeding everywhere and nothing else seems to be amiss. Not sure what would have caused it to blow...
by xbilx
Tue Apr 18, 2017 8:33 am
Forum: Rectifier Series
Topic: 2-channel triple troubleshooting help
Replies: 7
Views: 2831

Re: 2-channel triple troubleshooting help

was working fine last night and again this morning. Last night had it turned up more on both channels. This AM i had the volume pretty low on both channels, was playing a while then i turned up the volume a touch and it went out again...just like a power drop. so baffling.
by xbilx
Mon Apr 17, 2017 8:17 am
Forum: Rectifier Series
Topic: 2-channel triple troubleshooting help
Replies: 7
Views: 2831

Re: 2-channel triple troubleshooting help

still having trouble...thinking it may be time for a tech visit. I changed all the tubes, all the pre amps and still am getting a huge volume drop and playing sounds flubby and flat esp. on the low end. Every time i let it sit for a bit and it comes back like nothing happened but then does it again....
by xbilx
Wed Apr 05, 2017 3:13 pm
Forum: Rectifier Series
Topic: 2-channel triple troubleshooting help
Replies: 7
Views: 2831

Re: 2-channel triple troubleshooting help

Have you tried the amp with the FX loop set to "Loop Bypass"? Are you using Bold or Spongy, Tube Rectifier or Silicon Diode? Also, exactly what tubes did you replace, and what (brand) did you use. Certain 12AX7's do not hold up well in the cathode follower preamp positions, and have been known to f...
by xbilx
Tue Apr 04, 2017 11:01 pm
Forum: Rectifier Series
Topic: 2-channel triple troubleshooting help
Replies: 7
Views: 2831

2-channel triple troubleshooting help

Hello: Hoping someone maybe able to help me troubleshoot. I recently picked up a mesa triple rectifier, i have only been able to play it through my (crappy) marshall mg412 cab. Everything started off great but then i started to realize after an hour or so of playing the volume would all of a sudden ...