Search found 230 matches

by mace
Mon Oct 14, 2019 9:19 pm
Forum: Mark V
Topic: Channel 1 Distorting??
Replies: 12
Views: 1560

Re: Channel 1 Distorting??

I tried this tonight and could not duplicate it. With the EQ disengaged and Ch1 EQ set to PRESET I moved the dial on the PRESET from zero to full and back and forth. The tone stayed clean. I did the same with the EQ engaged and the tone stayed clean (but responded to the PRESET dial). As best I coul...
by mace
Mon Sep 23, 2019 6:57 am
Forum: Mark V
Topic: Crackle in lower watt settings
Replies: 6
Views: 299

Re: Crackle in lower watt settings

Good deal. I have found "crackling" noises (when nothing is playing but the amp is on) to always be caused by either a worn power tube or rectifier tube. Same for my stereo system amp.
by mace
Fri Sep 20, 2019 6:22 am
Forum: Mark V
Topic: Slave out for recording signal?
Replies: 4
Views: 341

Re: Slave out for recording signal?

yeah, the slave out is not really usable going straight to a mixer board or recorder or anything that needs a finished "line out" type of signal. It is a signal meant to go into another power amp.
by mace
Thu Sep 19, 2019 6:37 am
Forum: Mark V
Topic: Crackle in lower watt settings
Replies: 6
Views: 299

Re: Crackle in lower watt settings

I had a crackle a couple weeks ago and it ended up being the rectifier tube. Swapped it out with new and all is good. Hopefully that'll fix it for you also!
by mace
Tue Sep 10, 2019 6:25 am
Forum: TC50
Topic: TC-50 Guidance
Replies: 8
Views: 616

Re: TC-50 Guidance

Not sure I'll be of any help as you have more experience with amps than I do. And, you obviously know what tone you are after. I love the TC-50 but keep coming back to the Mark V. The Mark seems to be my "home base" amp. I have the TC-50 combo and for me it is pretty easy to dial in and I do not get...
by mace
Fri Aug 30, 2019 8:16 am
Forum: JP2C
Topic: Train of Thought settings
Replies: 2
Views: 290

Re: Train of Thought settings

Yeah, that album has a pretty distinct Recto style sound. Gnarly, nasty, big and open. A bit of a challenge to get a Mark to duplicate it.
by mace
Mon Aug 12, 2019 6:28 am
Forum: Mark V
Topic: New 6l6 441 tubes
Replies: 16
Views: 1002

Re: New 6l6 441 tubes

I''ll try to get some clips..... would not recommend holding breath.. They arrived earlier this week and I haven't put them in yet. I'm trying to really get my ears used to the current 440s so I play a while, with the intent of swapping them out. Then I get sidetracked learning some new songs or mes...
by mace
Tue Aug 06, 2019 8:59 pm
Forum: TC50
Topic: Speakers???
Replies: 2
Views: 254

Re: Speakers???

You may want to search for posts from ‘bandit2013’. He had lots of reviews on a lot of different speakers with different amps. Different cabinets too. He doesn’t post much anymore but was a wealth of info.

I also got the vertical 2x12 and really like the stock V30s.
by mace
Sun Aug 04, 2019 9:56 pm
Forum: Mark V
Topic: New 6l6 441 tubes
Replies: 16
Views: 1002

Re: New 6l6 441 tubes

Well, I ordered 4 of the 441s as my current 440 6L6s were getting long in the tooth. I’m curious about them. I found it interesting that Mesa now ships Mark Vs standard with these 441s.
by mace
Tue Jul 30, 2019 6:37 am
Forum: Mark V
Topic: New 6l6 441 tubes
Replies: 16
Views: 1002

Re: New 6l6 441 tubes

Interesting about that. I hadn't seen those before and didn't know they changed the stock tubes in the Mark V.

Does anyone know when they made that switch?
by mace
Fri Jun 21, 2019 6:21 am
Forum: Modern Era Amps (1991-Present)
Topic: I "Downgraded" from Mark V to Mark 1
Replies: 5
Views: 1758

Re: I "Downgraded" from Mark V to Mark 1

I've never played a Mark I personally. But, the Mark 1 MODE on the V has a pretty dark sounding tone, quite dark and rounded off. I do use that MODE once in a while for a nice thick crunch. How "true" is the Mark 1 MODE compared to an actual Mark I amp? Are their personalities in the ball-park to ea...
by mace
Fri Jun 14, 2019 6:13 am
Forum: Mark V
Topic: James hetfield with Mark V
Replies: 12
Views: 4158

Re: James hetfield with Mark V

Thanks much. Not the settings I use, no wonder I don't sound like Hetfield! Wonder what era he had that long hair in the last photo?... :mrgreen:
by mace
Fri May 31, 2019 3:33 pm
Forum: TC50
Topic: TC-50 clip
Replies: 2
Views: 521

Re: TC-50 clip

Dangz. I didn't see those TC-50 videos before (probably because they're in French!). But, I watched all 3, all the way through...I could understand about every third word. :) Thanks much and I really liked your songwriting and playing. The TC series is really special. I hope they come out with a toa...
by mace
Mon May 27, 2019 2:16 pm
Forum: TC50
Topic: Running two 8 ohms cabs on my Tc-50
Replies: 3
Views: 534

Re: Running two 8 ohms cabs on my Tc-50

Two cabs, each 8 ohms, and each plugged into the back of the amp requires that you set the switch to 4 ohms. That is correct. In fact, if you do not run with the switch at 4 ohms with two 8 ohm cabs hooked directly into the amp you could damage the amp. Not sure why you have a volume drop with that?...
by mace
Sat May 18, 2019 2:19 pm
Forum: Mark V
Topic: Mark V distasteful overdriven buzz
Replies: 8
Views: 1065

Re: Mark V distasteful overdriven buzz

I think I can hear that buzz the OP is talking about. But, it seems more pronounced with the mills V30 setup. If it can't be dialed out with presence or treble then I dunno. It doesn't sound normal per se, but not sure what settings the OP had for sure. I would agree if "trusting your ears" is the m...