Search found 41 matches

by jdgebha
Fri Mar 13, 2020 11:32 am
Forum: Mark V
Topic: Whats the deal with EL34 class tubes in the V
Replies: 5
Views: 927

Re: Whats the deal with EL34 class tubes in the V

If it just to save tubes thats one thing. But if its due to potential damage to grid resistors etc that’s another. I never did receive anything back from Mesa support.
by jdgebha
Thu Mar 12, 2020 6:18 am
Forum: Mark V
Topic: Whats the deal with EL34 class tubes in the V
Replies: 5
Views: 927

Whats the deal with EL34 class tubes in the V

I tried emailing Mesa but didn’t get a response. Can you run EL34 or KT77’s in full power mode or not? Whats the official word and the technical reasons for yes or no?
by jdgebha
Thu Feb 27, 2020 8:40 pm
Forum: Mark V
Topic: Mark V intermittent power and lights loss
Replies: 6
Views: 763

Re: Mark V intermittent power and lights loss

I had this issue and unfortunately it needed a power section fix from a tech. I would call Mesa first and see what they can offer as help.
by jdgebha
Tue Jan 28, 2020 1:07 pm
Forum: Mark V
Topic: Equalize
Replies: 8
Views: 977

Re: Equalize

I use a MXR 10 band in the loop. I cut out some fizz and boost the bottom end but the mids are flat. I use the gph eq onboard the amp for the levels.
by jdgebha
Sun Jan 12, 2020 6:09 pm
Forum: Mark V
Topic: MKV EQ switching issue - please help
Replies: 5
Views: 823

Re: MKV EQ switching issue - please help

I actually had something similar and it turned out to be the rectifier tube. Not sure why but I replaced it and all my eq switch issues went away.
by jdgebha
Mon Jan 06, 2020 11:45 am
Forum: Mark V
Topic: New boogie
Replies: 34
Views: 2788

Re: New boogie

Why not check tubes? Replace fuse. Try again.
by jdgebha
Sun Jan 05, 2020 2:05 pm
Forum: Mark V
Topic: The Mark V in general.
Replies: 5
Views: 1116

Re: The Mark V in general.

When I first got my Mark I realized right amp that my playing and technique were sounding awful. So much so in fact, I would not want to play it as much as my XXX. In the end I continued to work with it and after about a month I started to see big results with improved playing and greater rewards fr...
by jdgebha
Tue Nov 19, 2019 6:42 pm
Forum: Mark V
Topic: Problem with my FX Loop?
Replies: 10
Views: 1088

Re: Problem with my FX Loop?

Ok nice.
by jdgebha
Tue Nov 19, 2019 5:14 pm
Forum: Mark V
Topic: Problem with my FX Loop?
Replies: 10
Views: 1088

Re: Problem with my FX Loop?

Off topic. Whats your pedal board model? I need a mew one.
by jdgebha
Wed Nov 13, 2019 8:27 pm
Forum: Mark V
Topic: Mark V Graphic EQ Problem
Replies: 15
Views: 2118

Re: Mark V Graphic EQ Problem

Yeah I did. Started appearing on channel 2 and eventually 3 as well. Unfortunately I ultimately had to take it to a authorized repair place. I think it was a relay or diode issue.
by jdgebha
Mon Oct 07, 2019 4:39 pm
Forum: Mark V
Topic: Amp turning off and on again quickly
Replies: 28
Views: 12302

Re: Amp turning off and on again quickly

Had the exact same symptoms. Took to an authorized mesa tech and he a diode replacement and a power supply upgrade recommended by mesa. No probs a year amd a half later.
by jdgebha
Wed Aug 07, 2019 10:18 am
Forum: Mark V
Topic: Purchasing Full Set of Tubes for Mark V
Replies: 3
Views: 889

Re: Purchasing Full Set of Tubes for Mark V

Been using Eurotubes sets for my Mark. They resell JJs. They have been solid so far.
by jdgebha
Sun Aug 04, 2019 11:20 am
Forum: Mark V
Topic: Resin on tube sockets?
Replies: 2
Views: 558

Re: Resin on tube sockets?

Am wondering if it’s something with the Eurotube valves I buy. I noticed now they are stamping their name on the lower plastic rings right below the glass. Wondering if that where the resin is coming from. I’ve never seen it before on my other heads but I dont have the labeled tubes in those.
by jdgebha
Thu Aug 01, 2019 10:02 am
Forum: Mark V
Topic: Resin on tube sockets?
Replies: 2
Views: 558

Resin on tube sockets?

Was doing my annual tube refresh in my 90 watt head and noticed some kind of sticky brown resinous stuff on the power tube sockets. Anyone ever experience this and is it normal?
by jdgebha
Thu Jul 04, 2019 8:42 am
Forum: Mark V
Topic: Mark V with Revv g3/4 pedal
Replies: 8
Views: 1518

Re: Mark V with Revv g3/4 pedal

Honestly I don’t think the Mark V likes distortion or OD pedals much. Gets too mushy. Unless you are dialed waaay back on gain and even then I prefer the gain on both channels 2-3 over pedals. I do run a mojo mojo of on channel two for solos but i have gain in mark 1 mode about 1 o’clock max. Even t...