Search found 69 matches

by kc_ksom
Mon Jul 29, 2019 2:29 am
Forum: Foot Pedals & Misc Mesa Stuff
Topic: Pod X3 Live & Mesa Boogie Triple Rectifier
Replies: 1
Views: 363

Re: Pod X3 Live & Mesa Boogie Triple Rectifier

You will be OK to hook it up through the fx loop and 4 cable method however the dual/triple have a parallel FX loop - so you will get an odd sounding delay tone etc when you hook the multi fx unit in the loop (this is due to how they send the signal from the multi fx unit) - so unless you modify the...
by kc_ksom
Thu Apr 11, 2019 12:44 am
Forum: Mark V
Topic: Mark V 25 seems dead
Replies: 5
Views: 833

Re: Mark V 25 seems dead

Awesome

Its good to know it was not much that went wrong in the scheme of things

Casey
by kc_ksom
Tue Apr 02, 2019 7:22 pm
Forum: Vintage Amps (Before 1991)
Topic: MARK III BLACK STRIPE SNAP CRACKLE POPPING
Replies: 14
Views: 1454

Re: MARK III BLACK STRIPE SNAP CRACKLE POPPING

hey I had similar noises from my Mark III The screen grid resistors were one problem (well a few problems) they were replaced them - and then replaced again.. I also found that after the tech had done some work it always use to crackle & pop on start up for a while before it would come good - someti...
by kc_ksom
Mon Mar 25, 2019 2:18 am
Forum: Mark V
Topic: Mark V 25 classic crunch?
Replies: 4
Views: 810

Re: Mark V 25 classic crunch?

Have you set your reverb up a little - on Zero this will have a dry tight feeling - I always have a little verb on

Casey
by kc_ksom
Thu Jan 17, 2019 2:09 am
Forum: Rigs & Tones
Topic: Mark V 35 MKIIC+ crunch tones!
Replies: 1
Views: 1010

Re: Mark V 35 MKIIC+ crunch tones!

Man - nice tones - cool song - did you write that ??

Casey
by kc_ksom
Thu Jan 17, 2019 1:59 am
Forum: Vintage Amps (Before 1991)
Topic: New Amp Day - $200 Edition
Replies: 2
Views: 669

Re: New Amp Day - $200 Edition

That's a ripper - you cant complain about that, I also had a similar deal on a blue stripe only I have now repaired mine 3 times and still its not 100% but gezz it still sounds good.

Casey
by kc_ksom
Mon Jan 14, 2019 12:44 am
Forum: Mark Series
Topic: Mark IV - Worth getting?
Replies: 15
Views: 2291

Re: Mark IV - Worth getting?

Did you end up buying it - I was going too I just couldn't get the funding from the Mrs - Its a cool amp for sure - US voltage was a pain but still for what he was asking for it was a bargin anyway

Casey
by kc_ksom
Fri Dec 14, 2018 1:33 am
Forum: Mark Series
Topic: Mark 2c+ - Guts shot questions - Boogiebabies
Replies: 7
Views: 1300

Re: Mark 2c+ - Guts shot questions - Boogiebabies

Cool amp mate - what part in Australia are you from - I would recommend just going to Pro Audio in Canberra they are the dealer - the tech there is very cluey, he may want to replace all the components though? - there is also another guy here on the forum that posts by the name Mcbarry he is also ve...
by kc_ksom
Mon Aug 13, 2018 1:35 am
Forum: Mark V
Topic: Looking for a tone not sure how to describe
Replies: 6
Views: 1498

Re: Looking for a tone not sure how to describe

I would set to extreme mode as well and bring your gain down to the playing volume you want while your master volume is at 60% plus - get the tubes to work a little more, set your bass up and mids up a little to compensate

casey
by kc_ksom
Tue Jun 05, 2018 9:46 pm
Forum: Mark Series
Topic: Mark III blue stripe 6ow - low output on clean channel
Replies: 11
Views: 4209

Re: Mark III blue stripe 6ow - low output on clean channel

Hi Jon


I still have not pulled the chassis out to check or take a pic but if you send me your email I will flick you a picture as soon as I take one - I don't have an online picture storage account anymore for forum pics so it might be easier just to do via email etc

cheers mate


Casey
by kc_ksom
Sun May 13, 2018 6:47 pm
Forum: Mark Series
Topic: Mark III blue stripe 6ow - low output on clean channel
Replies: 11
Views: 4209

Re: Mark III blue stripe 6ow - low output on clean channel

Hey fellas Thanks for the replys and the help - I haven't pulled it apart just yet but I will do that in the next week or so - I fired it up yesterday as its been sitting for a long time as I mostly play the Mark V 25 now, but gezz this amp sounds good, I have always loved the sound this amp has, it...
by kc_ksom
Fri May 11, 2018 1:46 am
Forum: Mark Series
Topic: Mark III blue stripe 6ow - low output on clean channel
Replies: 11
Views: 4209

Re: Mark III blue stripe 6ow - low output on clean channel

Hi mate I pretty sure your from AGGH - ha Yea its frustrating but I don't have a foot switch to test - all channels sound great but just lower volume for clean and even lower for R2. All functions work and I believe that BJ Amps fixed the initial issue with the intermittent crackling, during palm mu...
by kc_ksom
Thu May 10, 2018 10:13 pm
Forum: Mark Series
Topic: Mark III blue stripe 6ow - low output on clean channel
Replies: 11
Views: 4209

Mark III blue stripe 6ow - low output on clean channel

Hi Just wanted to see if there was an easy fix - I have had this amp fixed several times for other reasons to this problem - all though the last time that it was fixed I thought that he sorted it as it sounds very good but I didn't really turn up the volume past 2 but I now notice that the clean out...
by kc_ksom
Mon May 22, 2017 9:50 pm
Forum: Mark V
Topic: Mark V FX loop treble loss
Replies: 8
Views: 2172

Re: Mark V FX loop treble loss

The Mark III loop is in a different position to the Mark V loop, Im pretty sure its after the preamp stage - The Mark V is directly into the preamp stage, so that is probably what you can hear. I know when I play the delay and reverb in my Mark III it sounds great through the loop - I can play a rif...