Search found 179 matches

by Eevil
Mon Jan 25, 2021 12:33 am
Forum: Vintage Amps (Before 1991)
Topic: Mark III Ghost Notes (help!)
Replies: 5
Views: 251

Re: Mark III Ghost Notes (help!)

Just a thought...

I don’t know if it’s safe to test the amp without simul class tubes. If the pair is wired in triode (pre green stripe) that could produce some ghosting in tone (at least does in my XTC)
by Eevil
Mon Jan 04, 2021 3:04 pm
Forum: Foot Pedals & Misc Mesa Stuff
Topic: The Multimeter Cannot Lie.....right?
Replies: 2
Views: 225

Re: The Multimeter Cannot Lie.....right?

Hello.

Multimeter doesn’t lie about the resistance it is measuring. The impedance is not the same as resistance (google - my English is not good enough to explain the difference)

But the readings you’re getting are normal for 1x 8ohm mono - 2x 4ohm cab :mrgreen:
by Eevil
Tue Nov 10, 2020 2:37 pm
Forum: Mark V
Topic: Back of amp flashes with a blue light when turning amp on
Replies: 9
Views: 630

Re: Back of amp flashes with a blue light when turning amp on

Some power tubes flash when they’re powering up :) I’ve thought it’s normal..
by Eevil
Tue Nov 10, 2020 7:07 am
Forum: Mark Series
Topic: Mark IV-A or IV-B
Replies: 3
Views: 621

Re: Mark IV-A or IV-B

Hi. I’ve no insight on Mark IV but I had Mark III blue stripe... it had GEQ - which was optional. I think most Mark IIIs are still equipped with GEQ. The issue with Mark III vs IV is the shared controls (bass/mid/treble) for all three modes (rhythm 1,2 and lead). In Mark IV there was only two shared...
by Eevil
Fri Oct 16, 2020 2:00 pm
Forum: Mark Series
Topic: Mark IV No Sound / Not Working
Replies: 15
Views: 1139

Re: Mark IV No Sound / Not Working

Hello.

Have you tried if it’s silent from all speaker outs? (4ohm and both 8ohms?)
by Eevil
Mon Oct 12, 2020 11:08 pm
Forum: Vintage Amps (Before 1991)
Topic: Educate Me on Mark III Clean Tones!
Replies: 10
Views: 1263

Re: Educate Me on Mark III Clean Tones!

In my experience the Mark III clean tones are top notch. :mrgreen: But for me the clean tones are pretty wimpy when the amp is first set to killer lead tones. They are of course a lot better than many other amps I’ve tried :mrgreen: but still not perfect. Vice versa the lead tones are too bloated if...
by Eevil
Sat Oct 03, 2020 2:30 pm
Forum: Tubes
Topic: Tube advice for MESA Studio Preamp
Replies: 6
Views: 1119

Re: Tube advice for MESA Studio Preamp

FYI- The current Mesa branded 12AX7’s are JJ ECC83’s. Preamp tubes really don’t need changing unless there is an issue (noise, volume drops, etc). I thought that the current Mesa JJ tubes would be the ECC83MG not the ECC83... not sure though. But the aforementioned Studio pre tubes were originals f...
by Eevil
Sat Oct 03, 2020 8:00 am
Forum: Tubes
Topic: Tube advice for MESA Studio Preamp
Replies: 6
Views: 1119

Re: Tube advice for MESA Studio Preamp

I think the Mesa branded would be pretty good (newer ones or Chinese). Previous occasion when I had the Studio pre i retubed it with JJ ecc83s and it was horrible :lol: no highs and lows were muffled... FYI- The current Mesa branded 12AX7’s are JJ ECC83’s. Preamp tubes really don’t need changing un...
by Eevil
Fri Oct 02, 2020 2:28 pm
Forum: Tubes
Topic: Tube advice for MESA Studio Preamp
Replies: 6
Views: 1119

Re: Tube advice for MESA Studio Preamp

Hi. I think the Mesa branded would be pretty good (newer ones or Chinese). Previous occasion when I had the Studio pre i retubed it with JJ ecc83s and it was horrible :lol: no highs and lows were muffled... Later on I swapped the original Mesas back in there and it was back to life -experience. Why ...
by Eevil
Fri Sep 25, 2020 9:01 am
Forum: Rack Pieces
Topic: Triaxis latest version any good?
Replies: 5
Views: 625

Re: Triaxis latest version any good?

Steve560 wrote:
Fri Sep 25, 2020 2:47 am
Sounds like a high frequency ground loop hum, but I have that already when it's only on without guitar input or anything else.
What’s your power amp?
by Eevil
Thu Sep 24, 2020 12:09 am
Forum: Vintage Amps (Before 1991)
Topic: Mark III Black Dot
Replies: 5
Views: 717

Re: Mark III Black Dot

Congrats!

I used to have a 60w Mark III blue stripe combo and it was just pain to carry anywhere :lol: be it with a C90 or an EVM it was heavy... and when I finally bought a case for it... oh my...
by Eevil
Thu Sep 24, 2020 12:04 am
Forum: Rack Pieces
Topic: Triaxis latest version any good?
Replies: 5
Views: 625

Re: Triaxis latest version any good?

Steve560 wrote:
Wed Sep 23, 2020 2:48 pm
Sounds great but I have a lot of high frequency hum in LD1. :shock: Is this normal?
White noise? Or something else?
by Eevil
Wed Sep 23, 2020 12:33 pm
Forum: Amps
Topic: So, what amps do you own?
Replies: 216
Views: 132591

Re: So, what amps do you own?

Some changes... Only Bogner XTC Classic + Mesa 4x12 trad slanted and Mesa ED 1x12 Combo left :)